Issue with Electronic Agreements loading
Incident Report for Glofox
Resolved
This issue has now been resolved.
Posted Sep 26, 2023 - 18:54 UTC
Monitoring
Our 3rd party provider has implemented a fix and Glofox Electronic Agreements should now be functioning correctly. We are monitoring this closely to ensure the problem has been fully mitigated.
Posted Sep 26, 2023 - 18:47 UTC
Identified
Our 3rd party provider has identified the issue and we are working with them to resolve this as soon as possible. Thank you for your patience.
Posted Sep 26, 2023 - 18:29 UTC
Investigating
We are currently investigating an issue with a 3rd party which is slowing down the creation of Electronic Agreements.
Posted Sep 26, 2023 - 17:33 UTC
This incident affected: Glofox Application.