Degraded Performance - Glofox Reporting
Incident Report for Glofox
Resolved
We have now confirmed that performance is back to normal and we apologize for any inconvenience caused by this. If you need to contact our support team, you can do so via support@glofox.com
Posted Mar 29, 2023 - 23:08 UTC
Update
We are continuing to investigate this issue.
Posted Mar 29, 2023 - 23:06 UTC
Investigating
We are currently experiencing an issue that may impact reports. Further updates will be available shortly. We apologise for the inconvenience in the meantime.
Posted Mar 29, 2023 - 22:44 UTC
This incident affected: Glofox Application.