Degraded Performance
Incident Report for Glofox
Resolved
This incident has been resolved. Should you continue to experience any issues, please contact our support team. Thanks again for your patience.
Posted Jun 22, 2020 - 10:36 UTC
Identified
The issue has been identified and a fix is being implemented, please bear with us and thank you for your patience.
Posted Jun 22, 2020 - 10:25 UTC
Investigating
We are currently experiencing degraded performance across our platform in all regions. We are investigating the issue and will have an update soon.
Posted Jun 22, 2020 - 09:48 UTC