Degraded Performance
Incident Report for Glofox
Resolved
This incident has been resolved.
Posted Dec 29, 2020 - 15:09 UTC
Identified
The issue has been identified
Posted Dec 29, 2020 - 14:10 UTC
Investigating
We are currently experiencing degraded performance across our platform in all regions. We are investigating the issue and will have an update soon.
Posted Dec 29, 2020 - 13:23 UTC