Degraded Performance - Memberships Tab
Incident Report for Glofox
Resolved
This incident has been resolved.
Posted Sep 07, 2020 - 09:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 07, 2020 - 09:51 UTC
Investigating
We are currently experiencing an issue with degraded performance on the Membership Tab of the dashboard. We are investigating the issue and will have an update soon.
Posted Sep 07, 2020 - 09:42 UTC