Degraded Performance - Memberships
Incident Report for Glofox
Resolved
This incident has been resolved.
Posted Dec 16, 2021 - 02:35 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2021 - 02:22 UTC
Investigating
We are currently experiencing an issue that may impact the purchase of memberships. Further updates will be available shortly. We apologise for the inconvenience in the meantime.
Posted Dec 16, 2021 - 02:06 UTC