Degraded Performance
Incident Report for Glofox
Resolved
This incident has been resolved.
Posted Apr 11, 2020 - 20:15 UTC
Investigating
We are currently experiencing degraded performance across our platform in all regions. We are working to resolve this issue with our third party hosting providers and will have an update soon.
Posted Apr 11, 2020 - 19:55 UTC