Degraded performance - North America

Incident Report for Glofox

Resolved

This incident had been resolved and Glofox is now fully operational in North America. No other regions were impacted.
Posted Jun 11, 2021 - 16:46 UTC

Monitoring

We have an identified an issue with Cloudflare, a third party provider to Glofox that is impacting customers in North America. We have taken steps to redirect traffic and the service is recovering.

If you are experiencing issues, please ‘Hard Refresh’ your browser (CTRL + Shift + R on Windows / cmd + shift + R on Mac) and attempt to reload Glofox.
Posted Jun 11, 2021 - 16:42 UTC
This incident affected: Glofox Application.